Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
View
Go to last post Go to first unread
francolargo  
#1 Posted : Monday, March 18, 2019 1:09:05 AM(UTC)
francolargo

Rank: Member

Groups: Member
Joined: 4/21/2007(UTC)
Posts: 60
Location: Minnesota

First, I wouldn't blame anybody for ignoring this question because it arises based on an extreme modification. As you may recall, I've been experimenting with subbing 3886 chips into the simpatico for the LM4780. The goal is to get more bass punch with better thermal management. My first attempt was very pleasing but ended with an unlucky ESD event.

Try two has been frustrating. Maybe I've been too clever by half, but I adapted old TPA amp boards with the correct sockets and capacitors to mount and connect the new 3886s. Pix here

Problem: the minus-side 3886s are putting out DC of nearly full input voltage (36 volts), while the plus side circuits seem to be functioning normally. This happens even with the input signal plus and minus pins disconnected from the simpatico board. I've triple-checked all the connections and can find no errors, shorts, polarity crosses, etc. The 3886s have insulated cases. The only grounds to the 3886s are via the sympatico sockets, but plus and minus speaker output is not returned to the sympatico board. I carefully replaced the two chips that were putting out huge DC, but no change. There is no heat or other worrying signs.

Clearly, I'm overlooking something major. Thoughts?

Frank
Brian Donegan  
#2 Posted : Monday, March 18, 2019 12:53:40 PM(UTC)
Brian Donegan

Rank: Administration

Groups: Administration, Customer
Joined: 10/24/2006(UTC)
Posts: 2,809
Location: Massachusetts, USA

Thanks: 2 times
Was thanked: 127 time(s) in 122 post(s)
"but plus and minus speaker output is not returned to the sympatico board"

No feedback loop? That would be bad.
francolargo  
#3 Posted : Monday, March 18, 2019 2:59:28 PM(UTC)
francolargo

Rank: Member

Groups: Member
Joined: 4/21/2007(UTC)
Posts: 60
Location: Minnesota

Originally Posted by: Brian Donegan Go to Quoted Post
"but plus and minus speaker output is not returned to the sympatico board"

No feedback loop? That would be bad.


OY!!! d'oh!

We researchers learn by our mistakes! Brick wall
I brought the plus outputs through the sympatico board for a more convenient wire connection, but not the minus outputs. Will fix.

BTW, the mistake on the original sympatico-3886 was taking the green plastic shell off of the power terminal blocks so that they would solder in more firmly. The metal corners barely overlapped the ground plane and it seems the ESD cut through the varnish and shorted one minus voltage.

Thanks, Amigo



francolargo  
#4 Posted : Monday, March 18, 2019 7:39:23 PM(UTC)
francolargo

Rank: Member

Groups: Member
Joined: 4/21/2007(UTC)
Posts: 60
Location: Minnesota

All is well after the quick addition of 2 more wires.

The Sympatico 3886 channels now put out 27 and 40 mV DC with 36.5V rails. Thats with a little increase in gain by subbing 1.6K resistors in at R1 & R2. I did it that way to exactly copy what was working well on the old 3886 amp.

The new, 100% stock Sympatico 4780 (in the same chassis, separate transformer) puts out 25 and 42 mV running on 32V rails.

...and they are making music now... Angel

Cheers,

Frank

Rss Feed  Atom Feed
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.