Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
View
Go to last post Go to first unread
Possum  
#1 Posted : Wednesday, May 2, 2018 4:34:56 AM(UTC)
Possum

Rank: Member

Groups: Member
Joined: 8/5/2012(UTC)
Posts: 168
Australia

Thanks: 4 times
Was thanked: 8 time(s) in 6 post(s)
I've just had a second failure of a 3.3v Series Trident. My latest 9038 build has been working for a couple of weeks. Left it on for a couple of days to finish burning it in and it suddenly stopped working.

The 3.3v SR on the XO inexplicably died. I am using a diyinhk 5v series regulator in front of a placid HD. The voltage was exactly 5V.

Precisely the same thing happened to my first 9038 build (except on the other 3.3v SR). It ran fine for a few days before a Trident died for no good reason.

Both failures cause a dead short across GND and VIN. Luckily the placid shunt reg handles dead shorts reasonably gracefully by dropping the voltage.

I see someone had a similar issue with the 1.2v SR Trident. That one does get quite hot on the 9038 compared to the 3.3v

I have upgraded to SR Tridents on all my 9018 boards without issue. Am in the process of replacing the DAC chips in all those boards tho and this issue concerns me as I was looking to use only the 5v linear reg due to room constraints.

Perhaps I need to consider using a fuse?
Rss Feed  Atom Feed
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.