Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Login


2 Pages12>
Options
View
Go to last post Go to first unread
fernfrost  
#1 Posted : Wednesday, October 7, 2015 7:51:57 PM(UTC)
fernfrost

Rank: Member

Groups: Member
Joined: 9/23/2015(UTC)
Posts: 86
Sweden

Thanks: 5 times
Hi

Just placed an order for a Buffalo IIIse. Feels like christmas!:)

I will be posting as the project progress and advice and input is always welcome.
Russ White  
#2 Posted : Monday, October 12, 2015 9:24:12 PM(UTC)
Russ White

Rank: Administration

Groups: Administration, Customer
Joined: 10/24/2006(UTC)
Posts: 3,979
Location: Nashville, TN

Thanks: 25 times
Was thanked: 89 time(s) in 83 post(s)
Can't wait to hear how you like it.

Take your time. Enjoy the ride.

Cheers!
Russ
fernfrost  
#3 Posted : Friday, October 16, 2015 6:10:25 PM(UTC)
fernfrost

Rank: Member

Groups: Member
Joined: 9/23/2015(UTC)
Posts: 86
Sweden

Thanks: 5 times
My package arrived today!

Here's what was in it:

Buffalo IIIse
Legato
Amanero USB receiver
Placid HD and Placid HD BP + power transformers


Buffalo IIIse
Buffalo IIIse


Legato
Legato


Amanero
Amanero USB


Placid HD
Placid HD


Placid HD BP
Placid HD BP


Power transformers and mount
Power transformers
Power transformer mount



Starting on the placids now:)

Edited by user Friday, October 16, 2015 6:16:18 PM(UTC)  | Reason: Not specified

fernfrost  
#4 Posted : Friday, October 16, 2015 6:38:58 PM(UTC)
fernfrost

Rank: Member

Groups: Member
Joined: 9/23/2015(UTC)
Posts: 86
Sweden

Thanks: 5 times
All parts for Placid HD

Placid HD Parts
Russ White  
#5 Posted : Friday, October 16, 2015 10:05:30 PM(UTC)
Russ White

Rank: Administration

Groups: Administration, Customer
Joined: 10/24/2006(UTC)
Posts: 3,979
Location: Nashville, TN

Thanks: 25 times
Was thanked: 89 time(s) in 83 post(s)
Let the fun begin!
Brian Donegan  
#6 Posted : Saturday, October 17, 2015 2:08:47 AM(UTC)
Brian Donegan

Rank: Administration

Groups: Administration, Customer
Joined: 10/24/2006(UTC)
Posts: 2,865
Location: Massachusetts, USA

Thanks: 2 times
Was thanked: 138 time(s) in 133 post(s)
This Amanero kit is slightly atypical...

UserPostedImage

Since he is going straight to the Buffalo, I flashed it appropriately and included a 6-pin connector and wire for routing the I2S to the Buffalo from the Amanero header.
fernfrost  
#7 Posted : Saturday, October 17, 2015 12:24:01 PM(UTC)
fernfrost

Rank: Member

Groups: Member
Joined: 9/23/2015(UTC)
Posts: 86
Sweden

Thanks: 5 times
Very much appreciated!

I might need some help down the road figuring out the pins.
fernfrost  
#8 Posted : Saturday, October 17, 2015 12:44:54 PM(UTC)
fernfrost

Rank: Member

Groups: Member
Joined: 9/23/2015(UTC)
Posts: 86
Sweden

Thanks: 5 times
Placid HD assembled

I really like the numbered parts system. Simple and straight-forward.

Placid HD
fernfrost  
#9 Posted : Saturday, October 17, 2015 12:46:57 PM(UTC)
fernfrost

Rank: Member

Groups: Member
Joined: 9/23/2015(UTC)
Posts: 86
Sweden

Thanks: 5 times
All parts for Placid HD BP

Placid HD BP
fernfrost  
#10 Posted : Saturday, October 17, 2015 1:39:13 PM(UTC)
fernfrost

Rank: Member

Groups: Member
Joined: 9/23/2015(UTC)
Posts: 86
Sweden

Thanks: 5 times
Placid HD BP assembled

Really happy with how it turned out. Learned a lot from doing the Placid HD first.

Placid HD BP

Placid HD BP
fernfrost  
#11 Posted : Saturday, October 17, 2015 1:45:40 PM(UTC)
fernfrost

Rank: Member

Groups: Member
Joined: 9/23/2015(UTC)
Posts: 86
Sweden

Thanks: 5 times
All parts for Legato

Legato
fernfrost  
#12 Posted : Saturday, October 17, 2015 4:36:41 PM(UTC)
fernfrost

Rank: Member

Groups: Member
Joined: 9/23/2015(UTC)
Posts: 86
Sweden

Thanks: 5 times
Legato assembled

Legato
fernfrost  
#13 Posted : Saturday, October 17, 2015 6:21:48 PM(UTC)
fernfrost

Rank: Member

Groups: Member
Joined: 9/23/2015(UTC)
Posts: 86
Sweden

Thanks: 5 times
Parts for Buffalo IIIse

Buffalo
fernfrost  
#14 Posted : Saturday, October 17, 2015 6:23:13 PM(UTC)
fernfrost

Rank: Member

Groups: Member
Joined: 9/23/2015(UTC)
Posts: 86
Sweden

Thanks: 5 times
Buffalo IIIse assembled

Buffalo

Buffalo

Buffalo
fernfrost  
#15 Posted : Saturday, October 17, 2015 7:22:23 PM(UTC)
fernfrost

Rank: Member

Groups: Member
Joined: 9/23/2015(UTC)
Posts: 86
Sweden

Thanks: 5 times
Buffalo IIIse mounted on Legato. I had to trim down some of the soldering on the Buffalo for the two boards to fit nicely. Now it looks great:)

Buffalo and Legato

Buffalo and Legato
fernfrost  
#16 Posted : Tuesday, October 20, 2015 2:05:36 PM(UTC)
fernfrost

Rank: Member

Groups: Member
Joined: 9/23/2015(UTC)
Posts: 86
Sweden

Thanks: 5 times
Manged to fry my Placid HD BP by putting my multimeter where it shouldnt be. Epic frustration!

New one on order and moving forward with making a platform for my test rig.
fernfrost  
#17 Posted : Saturday, October 31, 2015 1:10:17 PM(UTC)
fernfrost

Rank: Member

Groups: Member
Joined: 9/23/2015(UTC)
Posts: 86
Sweden

Thanks: 5 times
Got the new Placid HD BP yesterday and spent the day putting together a first go at the fully assembled dac.

It all works!:) And sounds fantastic!:)

Tuning the Legato is a very exact process and took a lot of time.


First go at assembly
Russ White  
#18 Posted : Sunday, November 1, 2015 12:49:38 PM(UTC)
Russ White

Rank: Administration

Groups: Administration, Customer
Joined: 10/24/2006(UTC)
Posts: 3,979
Location: Nashville, TN

Thanks: 25 times
Was thanked: 89 time(s) in 83 post(s)
Excellent work!
thanks 1 user thanked Russ White for this useful post.
fernfrost on 11/2/2015(UTC)
Jordo  
#19 Posted : Monday, November 2, 2015 8:49:26 AM(UTC)
Jordo

Rank: Member

Groups: Member
Joined: 12/7/2011(UTC)
Posts: 465
Location: Amsterdam

Thanks: 31 times
Was thanked: 4 time(s) in 3 post(s)
Hi fernfrost,

Nice to see you sharing your project like this!
Have good fun with it!

Grtz,

Jordo
fernfrost  
#20 Posted : Friday, November 6, 2015 4:46:37 PM(UTC)
fernfrost

Rank: Member

Groups: Member
Joined: 9/23/2015(UTC)
Posts: 86
Sweden

Thanks: 5 times
Have been test running the dac with SE outputs and it has been working really well.

Wanted to hook up my new mono blocks using balanced outputs and got really scared when there was no sound.
Posted a question about it : http://twistedpearaudio.com/forum/yaf_postst3740_No-sound-on-balanced-output.aspx

Some investigation later I found out that I need to add coupling capacitors.
Good read on this forum: http://twistedpearaudio.com/forum/yaf_postst2867_Legato-3-1-and-Ncore-issue--coupling-caps-or-other-solutions.aspx
Did a quick test with some 4,7 uF I had available and got the sound working. Phew!

There is a prominent buzzing sound that I am convinced is a grounding problem. Will move all components into real chassis and hoping that a more permanent installation will get rid of this problem.

Any and all input when it comes to coupling capacitors is highly welcome.
Rss Feed  Atom Feed
Users browsing this topic
2 Pages12>
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.